Add the option for users to disable or enable Unified Agent and WSS Agent.
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Add the option for users to disable or enable Unified Agent and WSS Agent.

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Article ID: 170969

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

You want to display the option for users to disable or enable Unified Agent (UA) or the WSS Agent (WSSA):

  • In the case of an environment causing connection issues or prevent the Unified Agent from passing web traffic to Cloud SWG (formerly known as WSS), you can configure Cloud SWG to allow employees to disable UA/WSSA should connection issues occur.
    • NOTE: Disabling UA/WSSA is permanent until the client is re-enabled.
  • You may have added this option and want to revoke that option.

Environment

The displaying of the enable or disable UA option is only available for Windows 7.x, 8.x, 10.x, and OSX 10.9 or later.

Cause

When the option for users to disable or enable UA is set to enabled:

  • If the UA is disabled, it remains disabled only until the client computer reboots or the employee reconnects from the Unified Agent interface.

  • Applies to all UA in the field.

    • NOTE: You cannot selectively target which installations receive the ability to view the disable UA option.

When the option for users to disable or enable UA is set to disable:

  • Users are not able to disable Unified Agent.

  • No command prompt to enable UA is available

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Resolution

  1. Log in to Portal.Threatpulse.com 
  2. Select Service Mode > Mobility > Unified Agent
  3. In the Unified Agent, Settings are located "Allow the agent to be disabled by end user" option.
  • Check to Enable this option
  • Uncheck to Disable this option

NOTE: Restart the Unified Agent´s connection to apply any changes made. You can renew the UA's connection by restarting the workstation or logging out from the Windows session.