Intermittent Internet access problems through the ProxySG (ComputerName$ or Anonymous users are cached in ProxySG)
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Intermittent Internet access problems through the ProxySG (ComputerName$ or Anonymous users are cached in ProxySG)

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Article ID: 171076

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Updated On:

Products

Advanced Secure Gateway Software - ASG ProxySG Software - SGOS

Issue/Introduction

1. Web Authentication Layer is enabled with IWA realm

2.  Management Console > Statistics > Authentication > Display by user
    The domain\ComputerName$ is authenticated and cached in ProxySG.

3. After administrator manually logs out the domain\ComputerName$, the user can access the Internet 
    Management Console > Statistics > Authentication > Display by user 
    The domain\username or Anonymous users are authenticated and cached in ProxySG.

Cause

This is a known issue unique to ProxySG deployments where IP-based authentication surrogate modes are used with IWA.

For the possible root causes, refer to Intermittent Internet access problems when running Windows 7 or Windows Vista through the ProxySG

Resolution

Common Solution is to implement Content Policy Language (CPL) to logout the ComputerName appended with $, and anonymous users.

<Proxy>
condition=SILENT_USERS realm=<REALM_NAME> user.login.log_out(true) 

define condition SILENT_USERS
  user="NT AUTHORITY\ANONYMOUS LOGON" 
  user="Anonymous logon" 
  user="NT AUTHORITY\Anonymous logon" 
  user.regex=".+\$$"
end