Metric Collector error due to missing metric
search cancel

Metric Collector error due to missing metric

book

Article ID: 171112

calendar_today

Updated On:

Products

Information Centric Analytics

Issue/Introduction

The following error is logged by the RiskFabric Processing job, or returned when the Metric Collector (RiskFabricCollector.exe) is executed manually:

Metric <MetricName> does not exist in <ServerName> <DatabaseName>

Environment

Version : 6.x

Component : RiskFabric Collector

Cause

The referenced metric (KPI) does not exist in the Information Centric Analytics (ICA) RiskFabric cube, hosted on the SQL Server Analysis Services (SSAS) server. This may be due to accidental deletion of the KPI from the location specified in the dbo.Metrics table in the RiskFabric SQL database.

Resolution

To resolve this error, first determine whether the referenced KPI is expected to be retained or deleted. The following query can be used to gather additional details to help make this determination:

SELECT     m.MetricKey,
m.ServerName,
      m.DatabaseName,
      m.CubeName,
      t.[Name],
      t.[Description] AS "Source Description",
      m.KPIName,
      m.[Description] AS "Metric Description",
      m.Query
FROM     RiskFabric.dbo.Metrics AS m
INNER JOIN RiskFabric.dbo.MetricSourceTypes AS t
ON         m.MetricSourceTypeID = t.MetricSourceTypeID
WHERE     m.KPIName = '';

NOTE: Modify the query to include the KPI name in the WHERE clause. For example:

WHERE      m.KPIName = 'Total DIM Incidents Last 30 Days';

If the KPI is to be retained, re-create the metric in the location identified by the query (e.g., Analyzer). Out-of-the-box KPIs are located in the ICA cube on the SQL Server Analysis Services server and can only be restored from a backup of the RiskFabric cube database or scripted from another instance of ICA. For assistance with this process, contact Broadcom Support.

If the missing KPI is no longer required, contact Broadcom Support for assistance with removing the KPI reference.