ICAP error after downloading files through the Web Security Service
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ICAP error after downloading files through the Web Security Service

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Article ID: 171198

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

Password-protected file downloads are configured to be allowed. However you get ICAP error after files are downloaded through the Web Security Service (WSS) because the files are sent over ICAP to be scanned.

ICAP Error

An error occurred while performing an ICAP operation: "File is password protected"

Tech support information: icap_error

Environment

Web Security Service

Cause

Malware scanning often rejects password-protected archives, causing an ICAP error to occur during the attempt to download. 

Resolution

WSS allows exemption to specific file types from ICAP errors by allowing them to be sent to the client.

Steps to add Password Protected Archives to scanning exemptions. 

  1. Log into Threatpulse Portal. http://portal.threatpulse.com
  2. Navigate to the Solutions mode, selecting Threat Protection then Content Analysis.

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      3. Scroll down to Scanning Error Handling and click the Add Scanning Error Exemption button.      

                

      4. Create a Scanning exemption: 

                 

      5. Go to Add Error Type Conditions and select the Add Password Protected Archives option.

               

      6. Click Save and Activate.