ICAP error on password protected file
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ICAP error on password protected file

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Article ID: 171378

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

Customer noticed ICAP_error screen, with the message:
   

    "File is password protected; File: foo.zip; Sub File: ; Vendor: Symantec...
    There could be a network problem, the ICAP service may be misconfigured, or the ICAP server may have reported an error.
    Tech support information: icap_error"

Password protected Excel files blocked (not limited to only Excel files)

 

Environment

  • Cloud SWG
  • File types included but not limited to: Excel (.xlsx), PowerPoint (.ppt), Word (.doc)

Cause

Password protection makes it impossible to scan the file, and by default traffic is blocked when scanning is not possible.

Resolution

  • Log in to the Cloud portal and add the problematic URL to the Scanning Exemptions section.
      • This can be done by doing the following:

    1. Navigate to Policy > Content & Malware Analysis
    2. Expand the Scanning Exemptions section
    3. Select the Destinations tab and click "+ Add"
    4. Add the affected URL and select Add
    5. After this is complete, be sure to click the "Activate Policy" button in the upper right to enforce the change.

  • Adding the site to Scanning Exemptions will render it impervious to policy decisions, as it will no longer be going through its normal workflow. Please be as specific as possible when adding URLs to this category to avoid the unnecessary allowing of other sites.
  • For example, if the error screen shown above is citing the URL 'https://dropbox.com/data/directory/myFile.zip', adding 'dropbox.com' to Scanning Exemptions may be counterproductive, as it is a hosting domain used on many sites and can have unexpected results. Add full URLs when given the opportunity.