How to Remove old licenses from Enforce Server
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How to Remove old licenses from Enforce Server

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Article ID: 171496

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Updated On:

Products

Data Loss Prevention Enforce Data Loss Prevention

Issue/Introduction

The Enforce console reports more license counts after adding new license .slf file.

NOTE: There is no functionality to remove licenses from the Enforce UI

 

Environment

Symantec Data Loss Prevention (DLP) Enforce, 15.x, 16.x

Cause

The .slf file itself reflects the correct license count, however rather than replacing the old license file it was added to it.

 

NOTE:The enforce console does not replace old licenses and will only add to the license count. 

Resolution

To remove some or all of the licenses from the Enforce Server.

  1. Log into the Enforce system.
  2. Stop DLP Manager ServerService.
  3. Find and backup the contents of the license and config folders.
  4. Empty the license folder (default: ProgramData\Symantec\DataLossPrevention\EnforceServer\<version>\license), do not delete the license folder.
  5. Restart DLP Manager Server Service.

It will take a minute or two before you can log back into the Enforce console.  Once you log in, re add the licenses from the GUI.

  1. Go to: System >> Settings >> General >> Configure
  2. Browse to your licenses and add them one by one.
    You will need to save after browsing to each license and repeat.

 

 

Additional Information

Be aware, this may revert default settings on some Enforce configuration files.  
For the correct order to stop and stop the DLP Enforce services, see our KB article Id: 159970.
https://knowledge.broadcom.com/external/article?legacyId=TECH220062Restart DLP Enforce services in the correct order