Unified Agent service cannot be manually stop
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Unified Agent service cannot be manually stop

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Article ID: 171498

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

You are trying to manually stop the Unified Agent's service with the command prompt, but you are not able to, even though in the past you were.

Unified Agent service cannot be manually stopped

Cause

Old Unified Agent versions would allow the service to be stop from Command Prompt with proper Windows administrative permissions, but since version 4.6, for security reasons, this was modified and the service cannot be forcefully shut down from the Command Prompt.

Resolution

If you would like to troubleshoot a problem, or if you are currently experiencing problems with Unified Agent specifically, and would like to disable it, the only possibilities are:

  • If you would like to have one client computer unprotected: uninstall Unified Agent from that endpoint.
  • If you would like to have all client computers unprotected: go to portal.threatpulse.com > Service > Mobility > Unified Agent, check the option "Allow agent to be disabled by end user" (note that you do not need to press an "Activate" button, this option will be automatically downloaded to all Unified Agent clients connected to the Web Security Service).