http 404 error when accessing the Endpoint Protection Manager API website
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http 404 error when accessing the Endpoint Protection Manager API website

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Article ID: 171669

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Updated On:

Products

Endpoint Protection

Issue/Introduction

When attempting to access the Endpoint Protection Manager (SEPM) API website, you receive an HTTP 404 error.  Some files or folders appear to be missing from \%SEPM path%\tomcat\instances\sepm-api\webapps\sepm

HTTP 404 when accessing https://<SEPM IP>:8446/sepm

Cause

The Endpoint Protection Manager API can be updated through LiveUpdate.  If a process on the server prevents extracting the contents of the API update, the update may fail requiring manual intervention. 

Resolution

To manually force the API to reinstall, you can do the following. 

  1. Stop the SEMAPI service.
  2. Add scm.component.upgrade.minutes=10 to conf.properties.  
  3. Browse to %SEPM path%\tomcat\instances\sepm-api\webapps.  Backup sepm.war to a safe location, then delete the file. 
  4. Restart all of the SEPM services. 
  5. Wait 10 minutes for the sepm.war to reappear then check the API site. 
  6. Once the API site is working again, remove scm.component.upgrade.minutes=10 from conf.properties and restart the SEPM services. 

If the API fails to work after the sepm.war appears, check SepmComponentUpgradeTask logs in \tomcat\logs for errors.  (Note, this log will require FINEST logging)