Network Topology Viewer no device is shown when trying to select a device to choose as the root
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Network Topology Viewer no device is shown when trying to select a device to choose as the root

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Article ID: 171897

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Updated On:

Products

Altiris Network Discovery

Issue/Introduction

When using the Network Topology Viewer no device is shown after clicking to select a device as the root even when all device type options are selected.

Environment

ITMS 7.6, 8.x

Cause

This is caused by not including the root device and the devices connected to it in a single Network Discovery Task.

Resolution

To resolve this, use one of the two methods below.

SEED Device Method

  1. Under Manage>Jobs and Tasks, create a "Discover Network" task. This is found under the "Discovery and Inventory" section when creating a new Task (right-click>New>Task) within the System jobs and tasks folder.


  2. Choose the radial option "Scan network devices (ARP)".
  3. Input a SEED device IP Address. This address is typically a Router that contains information on many connected network devices in the environment.
  4. Save the task and schedule it to run.
  5. NOTE: In large environments the task may run for quite some time (days in extreme cases).

IP Range Method

  1. Create a "Discover Network" task within Jobs and Tasks. This is found under the "Discovery and Inventory" section when creating a new Task within the System jobs and tasks folder.
  2. Choose the radial option "Targeted network scan (Ping)".
  3. Include an IP range that includes the infrastructure device you wish to use as the root AND all devices connected to it. This is necessary for the task to properly have the connection data from all devices to make the proper map.
  4. Save the task and schedule it to run.