Active Directory Connector failure due to incorrect account credentials
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Active Directory Connector failure due to incorrect account credentials

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Article ID: 172061

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Updated On:

Products

Information Centric Analytics Data Loss Prevention Core Package

Issue/Introduction

The Bay Dynamics AD Connector Job fails and logs the following errors:

[1:ERROR] Program.Main() Exception caught in ActiveDirectoryImporter  System.Runtime.InteropServices.COMException (0x8007052E): The user name or password is incorrect.
[1:ERROR] Program.Main() ActiveDirectoryImporter import was not successful.  Process Exit Code 1.  The step failed.

Environment

Version : 6.x

Component : Active Directory Import Utility

Cause

This failure can be caused by any of the following conditions:

  1. The account name used to query the Active Directory (AD) domain controller is invalid
  2. The password for the account used to query the AD domain controller is invalid (typically expired)
  3. The password for the account used to query the AD domain controller has not been updated correctly and encrypted

Resolution

To update the password used by the Active Directory Import Utility to query AD domain controllers, follow this procedure:

  1. Using SQL Server Management Studio, connect to the database engine hosting the ActiveDirectoryDW data warehouse
  2. In Object Explorer, navigate to Databases > ActiveDirectoryDW > Tables
  3. Right-click the table dbo.Server and select Select Top 1000 Rows
  4. Note the ServerID of the AD server(s) to be updated
  5. In Object Explorer, navigate to SQL Server Agent > Jobs
  6. Right-click the Bay Dynamics AD Connector Job and select Properties
    The Job Properties - Bay Dynamics AD Connector Job window opens
  7. In the Job Properties - Bay Dynamics AD Connector Job window, select the Steps page
  8. In the Steps page, select the Edit button
    The Command window opens
  9. In the Command window, note the path to the ImportADUsersAndComputers.exe executable
  10. Open a command prompt as an administrator
  11. Navigate to the path identified in step 9
  12. Edit the following command to use the ServerID from step 4 and the new password for the account:
    ImportADUsersAndComputers.exe -setapipassword <ServerID to update> <password for the AD server>

    NOTE: If the AD password contains special characters, enclose the password in double quotation marks (i.e., ")

  13. Execute the command