CustomActionData is in incorrect user type error received when installing Enforce Server
search cancel

CustomActionData is in incorrect user type error received when installing Enforce Server

book

Article ID: 172211

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

You are installing the Data Loss Prevention (DLP) Enforce Server from the EnforceServer.msi using the wizard and have entered all the required fields. 
The progress bar begins but throws an error on "CustomActionData is in incorrect user type" reaching the 'Setting Administrator Password' stage.

 

Environment

15.x

Cause

In the installation log you may see a message like this: 

CustomActionData is in incorrect format

The DLP installer will fail if the service account used, or the administrator password provided has certain special characters. 

For example the character ";" when used with either the service account or the administrator account will cause the installer to fail with this error. 

Resolution

Modify the account credentials so they do not have any special characters. It may be best to use only numbers and letters. 

Then rerun the installation.

You may then change the credentials so the password meets your organisation's requirements after the installation has been completed.