Endpoint Protection client reports the "Firewall is not functioning correctly"
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Endpoint Protection client reports the "Firewall is not functioning correctly"

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Article ID: 172250

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Updated On:

Products

Endpoint Protection

Issue/Introduction

After upgrading Symantec Endpoint Protection (SEP) to 14 RU1 MP1 the client reports a firewall malfunction.

When opening the SEP client UI, you see an error message of:

Firewall is not functioning correctly. Your protection definitions may be damaged or your product installation may be corrupt.

teeferInstall.log contains the following errors:

ERROR: Call to installNetComponent() failed: 0x80070002
ERROR: Call to installNetComponent() failed: 0x80070002
InstallFirewall failed second attempt: 0x80070002

Environment

Windows

Cause

The Windows OS handles the uninstall/removal of drivers. In this particular case, it cannot find the appropriate oem*.inf file for teefer from the current/previous install. As a result, Windows is unable to properly remove teefer thus fails to install the new teefer driver resulting in a Firewall malfunction.
 

Resolution

This issue is fixed in Symantec Endpoint Protection 14.2. For information on how to obtain the latest build of Symantec Endpoint Protection, see Download the latest version of Symantec Endpoint Protection.