Endpoint Protection client stops communicating and "Services are stopped" message
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Endpoint Protection client stops communicating and "Services are stopped" message

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Article ID: 173017

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Updated On:

Products

Endpoint Protection

Issue/Introduction

  • The Symantec Endpoint Protection (SEP) client stops communicating with the Symantec Endpoint Protection Manager (SEPM)
  • The Symantec Endpoint Protection service is started, and the ccSvcHst.exe process running under the SYSTEM user is running.

Attempting to open the SEP client interface, displays the following message:

"Symantec Endpoint Protection cannot open because some Symantec services are stopped. Restart the Symantec services, and then open Symantec Endpoint Protection" 

Cause

This problem happens when a SEP client initiates a client-server communications heartbeat, and a location awareness change simultaneously. This causes a deadlock between the threads responsible for both of these functions - both threads require access to the same resource, and will both wait for the other to complete before accessing the resource. The deadlocked threads cause the ccSvchst.exe process responsible for these functions to hang.

Resolution

This problem is fixed in Symantec Endpoint Protection 14.2 RU1. This version of the SEP client adds functionality to resolve a deadlock between location switching and client heartbeat threads.

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