Messaging Gateway sometimes returns spf=neutral when no SPF record is found
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Messaging Gateway sometimes returns spf=neutral when no SPF record is found

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Article ID: 173019

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Sometimes the Symantec Messaging Gateway (SMG) returns a results of spf=neutral instead of spf=none when no SPF record is present.

Cause

The SMG's MTA implements a default result of 'spf=neutral' if no result is explicitly noted.  This means that if the DNS server returns any result for the domain in question, but does not return a SPF record, then the SMG will return spf=neutral.  If the DNS server does not return any results for the domain in question, then the SMG will return spf=none.

Resolution

No action is required as the SMG is working as designed. If there is a need to find out which DNS is having issues please do the following:

  1. Collect data about the problematic domain, gather the DNS IPs that are linked to SMG.
  2. Execute nslookup from CC using the support account searching for TXT record types.