"Unable to add socket watcher errors: Socket is closed" on multiple remote task servers.
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"Unable to add socket watcher errors: Socket is closed" on multiple remote task servers.

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Article ID: 173103

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Updated On:

Products

IT Management Suite Task Server

Issue/Introduction

The Customer has noticed many "Unable to add socket watcher errors: Socket is closed" in multiple remote task server logs.

Error processing incoming tickle connection. Unable to add socket watcher: Socket closed.

[Altiris.DotNetLib.Sockets.SocketClosedException @ Altiris.DotNetLib]

Environment

ITMS 8.1 RU6 and later

Cause

Known issue. Our Dev team fixed some areas to address this problem:

* trying to decrypt only 471 bytes in case of larger size, because of sent tickle packet(s) after registration data
* more logging regarding the tickle connection establishment
* IP address check "removed"
* lowered logging level for some errors, caused by current implementation of client registration within TS - actually no impact on client registration]

Resolution

This issue has been reported to the Symantec Development team. A fix is currently targeted for the ITMS 8.5 RU1 release.

A pointfix is available for those customers in ITMS 8.1 RU6. See INFO5026
A pointfix is available for those customers in ITMS 8.1 RU7. See INFO5191

Some of the changes done for this issue are:
   a) the messages "Unable to identify endpoint" must be as trace message
   b) the message  "Not registered endpoint is..." should not be at all - removed IP address check
   c) the message "Socket is closed" must be as trace message