Issues with earlier versions of VIP Access Desktop after upgrading to macOS 10.14 (Mojave)
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Issues with earlier versions of VIP Access Desktop after upgrading to macOS 10.14 (Mojave)

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Article ID: 173112

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Updated On:

Products

VIP Access for Desktop

Issue/Introduction

If you have VIP Access 1.0.4/2.0.3 or earlier, you will see a dialog box requesting a keychain password the first time that you start VIP Access after upgrading to macOS 10.14 (Mojave). However, there is no way to obtain the keychain password for VIP Access. The only other option is to click Deny, with the result that VIP Access will not be able to retrieve your credential ID, and your app will be assigned a new credential ID. You will need to register the VIP Access app with the new credential ID to use it for two-factor authentication.

Cause

New restrictions are introduced in macOS 10.14 that prevent VIP Access from accessing the existing credential store unless you provide the keychain password the first time that you start the app. Since the keychain password is not obtainable, VIP Access cannot retrieve the existing credential ID, and generates a new credential ID.

Resolution

If possible, upgrade VIP Access to the latest version (1.0.5 or later) before you upgrade to macOS 10.14. VIP Access is available at https://vip.symantec.com.

If you have already upgraded to macOS 10.14, upgrade to the latest version of VIP Access (1.0.5 or later) before starting VIP Access for the first time.

If you have already upgraded to macOS 10.14 and you have also started VIP Access, you will need to register the app for two-factor authentication at your enterprise and personal web sites using the new credential ID.

Whether you have upgraded to macOS 10.14 or not, Symantec recommends that you always upgrade to the latest version of the VIP Access app.