Cloned Patch Compliance report(s) displays "Unknown Error"
search cancel

Cloned Patch Compliance report(s) displays "Unknown Error"

book

Article ID: 173564

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Getting "Unknown Error" when attempting to view cloned patch compliance reports on Symantec Management Platform (SMP) console. The issue started after an upgrade to 8.5 RU1. These report cannot be edited or deleted.

Note: Default compliance reports for Patch Management Solution for Windows are listed under Reports> All Reports, Software> Patch Management> Compliance> Windows.

Following message appears in SMP logs when attempting to view the cloned report: 

"Failed to load parameter from xml (skipped):
<parameter><name>FilterCollection</name><description></description><required>false</required><nullable>true</nullable><parameterTypeGuid>40d6ba82-776b-4d89-b1a8-8322b6ca64f5</parameterTypeGuid><testValue></testValue><defaultValue>01024956-1000-4cdb-b452-7db0cff541b6</defaultValue><order>10</order><valueProvider classGuid="891d9058-6b53-4a59-8aff-cf9b4ba13976"><configuration readonly="False" hideOnError="False"><style labelVisible="True" linkInSummary="True" showNoControls="True" allowMultiSelect="False" /></configuration></valueProvider><requiredParameters /><configurationControlClassGuid>73bded50-f1aa-4ff4-a80e-a6c9e047d472</configurationControlClassGuid></parameter>

The specified GUID does not refer to a registered class: 891d9058-6b53-4a59-8aff-cf9b4ba13976"

Environment

SMP 8.5 RU1

Cause

These cloned reports created before a subsequent upgrade to 8.5 RU1, become corrupted due to the report GUIDs being changed. After an upgrade is complete, the database does not recognize these GUIDs and cannot display, edit, or delete these reports on the Console.

Resolution

Use the following SQL query to replace all cloned and corrupted report's GUIDs to the correct ones:

Declare @t as table (guid uniqueidentifier)
​Insert into @t 
 
select guid
from vitem 
where classguid = 'a968a2a6-c9b9-483b-b9e0-7f0b199f9da3' 
and 
(
ProductGuid ='B1338338-5575-4A27-9808-23BEC40D79FA' 
or ProductGuid = 'C6D19F78-1434-49AC-BEC8-D18255E99F58' 
or ProductGuid = 'C6D19F78-1434-49AC-BEC8-D18255E99F57' 
or ProductGuid = 'c6b52ec2-597c-4efe-8830-b92f11888a4a'
and state like '%891D9058-6B53-4A59-8AFF-CF9B4BA13976%'
 
update item 
set state = replace
(cast(state as nvarchar(max)), 
'valueProvider classGuid="891D9058-6B53-4A59-8AFF-CF9B4BA13976"', 
'valueProvider classGuid="fd8b9293-29b1-42e2-bac5-7774df8143cc"')
where guid in (select guid from @t)

Then refresh the reports page on SMP console. 

Note: Access to SQL server is required to run this query. It is always recommended to take a full backup of the database (Symantec_CMDB), before running any query directly on SQL server.