Unable to upgrade due to: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel
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Unable to upgrade due to: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel

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Article ID: 173819

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Updated On:

Products

IT Management Suite

Issue/Introduction

While upgrading to ITMS 8.5, messages like this one were noticed right before SIM (Symantec Installation Manager) failed to configure:

Failed: The underlying connection was closed: An unexpected error occurred on a send.

The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.

The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
   [System.Net.WebException @ System]
   at System.Net.WebClient.UploadFile(Uri address, String method, String fileName)
   at System.Net.WebClient.UploadFile(String address, String fileName)
   at Symantec.Installation.StatUploaderHelper.ReportFileToTelemetryServer(String telemetryServerUrl, String fileName, Int32& incurredTrafficBytes)

The remote certificate is invalid according to the validation procedure.

...

-----------------------------------------------------------------------------------------------------
Date: 30/10/2018 11:12:31 a. m., Tick Count: 1976281 (00:33:06.2810000), Size: 388 B
Process: SymantecInstallationManager (4196), Thread ID: 10, Module: SymantecInstallationManager.exe
 

Environment

Upgrade to ITMS 8.5

Cause

Improper configuration with SSL

Resolution

  1. Make sure to verify the following suggestions for TLS 1.2 are applied first:
    KB 172634 "Getting error during installation or upgrade: Configuration Task Configure Notification Server... Failed: The request was aborted: Could not create SSL/TLS secure channel."
    KB 172898 "Failing to install ITMS. ConfigureNS - task_Completed(): Configuration Task Pre-Configuring ... Failed: The underlying connection was closed: An unexpected error occurred on a send."
  2. Check that your active Agent Communication Profile (under SMP Console>Settings>Agents/Plug-ins>Symantec Management>Symantec Management Agent Communication Profiles) has all the TLS versions checked: TLS 1.0, 1.1, and 1.2.

    As well that the "HTTP" link is provided and the checkbox is ticked.