Getting entries about: Failed to establish main persistent server connection, error: Persistent connection is disabled (0x8FA50007)
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Getting entries about: Failed to establish main persistent server connection, error: Persistent connection is disabled (0x8FA50007)

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Article ID: 174089

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer is not using persistent communication in the environment, but the Agent GUI shows a warning stating "Persistent connection to task Server is terminated". They also see an informational message in the logs like these ones:


Failed to establish persistent TS connection, error: Persistent connection is disabled (0x8FA50007)
-----------------------------------------------------------------------------------------------------
Date: 3/6/2019 11:10:59 AM, Tick Count: 70964171 (19:42:44.1710000), Size: 343 B
Process: AeXNSAgent.exe (6612), Thread ID: 6656, Module: client task agent.dll
Priority: 4, Source: Client Task Agent


Failed to establish main persistent server connection, error: Persistent connection is disabled (0x8FA50007)
-----------------------------------------------------------------------------------------------------
Date: 3/6/2019 11:10:59 AM, Tick Count: 70964171 (19:42:44.1710000), Size: 333 B
Process: AeXNSAgent.exe (6612), Thread ID: 6656, Module: AeXNSAgent.exe
Priority: 4, Source: Agent

 

The Symantec Management Agent UI shows the following:

These are the related agent log entries around the message noticed:

Entry 1:
[1CF63423420, WS: 10CC] Validating connection to 'https://<SMPserver>.<yourdomain>.com:4726/Altiris/WebSockets' using 'Matching' profile
-----------------------------------------------------------------------------------------------------
Date: 3/6/2019 11:10:59 AM, Tick Count: 70964156 (19:42:44.1560000), Size: 383 B
Process: AeXNSAgent.exe (6612), Thread ID: 6656, Module: AeXNetComms.dll
Priority: 4, Source: SMAIO.WSTransport.ProfileMonitor

Entry 2:
[1CF63423420, WS: 10CC] Connection to 'https://<SMPserver>.<yourdomain>.com:4726/Altiris/WebSockets' using '{xxxxxxxx-5AA6-4E17-A908-289B9A5CC57A}' profile was validated successfully, persistent connection is disabled
-----------------------------------------------------------------------------------------------------
Date: 3/6/2019 11:10:59 AM, Tick Count: 70964156 (19:42:44.1560000), Size: 464 B
Process: AeXNSAgent.exe (6612), Thread ID: 6656, Module: AeXNetComms.dll
Priority: 4, Source: SMAIO.WSTransport.ProfileMonitor

Entry 3:
[1CF63420010, WS: 5CC] Validating connection to 'HTTPS://<SMPserver>.<yourdomain>.com:443/Altiris/WebSockets' using 'Matching' profile
-----------------------------------------------------------------------------------------------------
Date: 3/6/2019 11:10:59 AM, Tick Count: 70964156 (19:42:44.1560000), Size: 381 B
Process: AeXNSAgent.exe (6612), Thread ID: 6656, Module: AeXNetComms.dll
Priority: 4, Source: SMAIO.WSTransport.ProfileMonitor

Entry 4:
[1CF63420010, WS: 5CC] Connection to 'HTTPS://<SMPserver>.<yourdomain>.com:443/Altiris/WebSockets' using '{xxxxxxxx-315E-4881-8F9D-812E911DF388}' profile was validated successfully, persistent connection is disabled
-----------------------------------------------------------------------------------------------------
Date: 3/6/2019 11:10:59 AM, Tick Count: 70964171 (19:42:44.1710000), Size: 462 B
Process: AeXNSAgent.exe (6612), Thread ID: 6656, Module: AeXNetComms.dll
Priority: 4, Source: SMAIO.WSTransport.ProfileMonitor

Entry 5:
Failed to establish persistent TS connection, error: Persistent connection is disabled (0x8FA50007)
-----------------------------------------------------------------------------------------------------
Date: 3/6/2019 11:10:59 AM, Tick Count: 70964171 (19:42:44.1710000), Size: 343 B
Process: AeXNSAgent.exe (6612), Thread ID: 6656, Module: client task agent.dll
Priority: 4, Source: Client Task Agent

Entry 6:
Failed to establish main persistent server connection, error: Persistent connection is disabled (0x8FA50007)
-----------------------------------------------------------------------------------------------------
Date: 3/6/2019 11:10:59 AM, Tick Count: 70964171 (19:42:44.1710000), Size: 333 B
Process: AeXNSAgent.exe (6612), Thread ID: 6656, Module: AeXNSAgent.exe
Priority: 4, Source: Agent

Environment

ITMS 8.5

Cause

Known issue. This message should be ignored. This is a cosmetic issue that is not meant to be displayed.

Note: After 8.5 RU2 release, these warnings will not be displayed in the agent UI. However, these log entries will be still present as just Informational entry logs. 

In this case INFO message says “Persistent connection is disabled”.

The agent does not try establishing websocket connection, they can check that if they want, but agent needs to check if it needs to establish a connection before doing so and these entries show that agent in fact did check that it does not need to establish websocket connection.

Resolution

This issue has been addressed with ITMS 8.5 RU2 release. As well further improvements with Persistent Connections has been added to 8.5 RU4 and 8.6 Releases. It is strongly recommended that if you see this type of message to upgrade to a more recent release.