ICAP Warning Email Notifications
search cancel

ICAP Warning Email Notifications

book

Article ID: 175069

calendar_today

Updated On:

Products

Advanced Secure Gateway Software - ASG ProxySG Software - SGOS

Issue/Introduction

ICAP Queues are hanging due to the number clients visiting streaming sites (example: Video Website, Stock Market Tickers, et c.).

ICAP queued transactions occur when the connections in the connection pool between the ProxySG and the ICAP server are all busy processing requests.  This can be because of load or a delay in scanning on the ICAP server.

Queued ICAP, Slowness or latency

Environment

ASG (Advanced Secure Gateway)/SGOS (Secure Gateway Operating System) connected to ICAP server.

Cause

Anti-virus scanning can potentially increase request / response latency as said traffic is now being scanned for malicious content while also being evaluated by the current proxy policy. This is expected behavior. However, there are circumstances that can introduce a more serious issue if latency is found to have increased over time.

Resolution

To receive notifications the following items need to be configured.

  • Maintenance tab > Event Logging > Mail​ tab

 

  • Configure Email(s) that should receive notifications.
    1. Click the "New" button.
    2. Enter the email that should receive notifications.
    3. Click OK.



  • Configure SMTP Server
    1. Check the "Send Event Logs" checkbox
    2. Enter the SMTP server's hostname or IP address and Port number.
    3. Optional - Enter the email address that the email will be sent as.
    4. Click Apply

  • Maintenance tab > Health Monitoring > General tab
    • ICAP (Internet Content Adaptation Protocol) manageable queues.
      • ICAP Queued Connections
      • ICAP Deferred Connections
    • Configuration
  1. Highlight the ICAP service that you want to enable notification on.
  2. Click Edit
  3. Check the "Email" checkbox
  4. Click "OK"
  5. Click Apply

  • Critical Threshold: The number of connections in the given state
  • Time Threshold: The number of seconds between the time the "Critical Threshold" is checked.