Unable to register to Windows Server 2016 Task Servers if the Anonymous Authentication for the ClientTaskServer page is not set to Enable.
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Unable to register to Windows Server 2016 Task Servers if the Anonymous Authentication for the ClientTaskServer page is not set to Enable.

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Article ID: 176074

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Updated On:

Products

IT Management Suite Task Server

Issue/Introduction

The customer noticed that their Windows Server 2016 Site Servers tend to lose their [Task] registration. The customer noticed that if they Enable the Anonymous Authentication on the ClientTaskServer object in IIS, it allowed the [2016] Site Server to register itself and also allow clients to register to it.


Note: Starting with ITMS 8.1 release, the ClientTaskServer web object has its Anonymous Authentication set to Disabled by default.
 
The customer uses an ACC account (Altiris Connectivity Credentials), which is a Local Account to his machines.
The ACC is present on the site server, enabled and unlocked. In IIS, Anonymous Authentication is *enabled* on the ClientTaskServer page. In this condition, the Task server registers.
The ACC is present on the site server, enabled and unlocked. In IIS, Anonymous Authentication is *disabled* on the ClientTaskServer page. In this condition, the Task server *does not* register.

When we try from the browser to access this page (when anonymous authentication is disabled):
http://TaskServername/Altiris/ClientTaskServer/Register.aspx?lastResort=true&resourceGuid=da6c4ead-bd50-4c67-bd9f-1acb50183b4b&crc=0008000100001863

he gets a prompt page for credentials, he adds the ACC account and it displayed this page after trying 3 times:

HTTP Error 401.1 - Unauthorized You do not have permission to view this directory or page using the credentials that you supplied.

If we try using the AppID account, which is a domain account, when IE prompts for credentials, we get the expected registration page.

One thing that we saw in the Security Event logs on the Task Server when a client machine is trying to register to the task server is this:

An account failed to log on.

Subject:

Security ID: NULL SID
Account Name: -
Account Domain: -
Logon ID: 0x0

Logon Type: 3

Account For Which Logon Failed:
Security ID: NULL SID
Account Name: svcACC3
Account Domain:

Failure Information:
Failure Reason: The user has not been granted the requested logon type at this machine.
Status: 0xC000015B
Sub Status: 0x0


 

An account failed to log on.

Subject:
Security ID: NULL SID
Account Name: -
Account Domain: -
Logon ID: 0x0

Logon Type: 3

Account For Which Logon Failed:
Security ID: NULL SID
Account Name: svcACC3
Account Domain:

Failure Information:
Failure Reason: The user has not been granted the requested logon type at this machine.
Status: 0xC000015B
Sub Status: 0x0

Process Information:
Caller Process ID: 0x0
Caller Process Name: -

Network Information:
Workstation Name: CLNTBCKP2
Source Network Address: 10.64.5.120
Source Port: 62019

Detailed Authentication Information:
Logon Process: NtLmSsp
Authentication Package: NTLM
Transited Services: -
Package Name (NTLM only): -
Key Length: 0

This event is generated when a logon request fails. It is generated on the computer where access was attempted.

The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe.

The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).
The Process Information fields indicate which account and process on the system requested the logon.
The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.
The authentication information fields provide detailed information about this specific logon request.
- Transited services indicate which intermediate services have participated in this logon request.
- Package name indicates which sub-protocol was used among the NTLM protocols.
- Key length indicates the length of the generated session key. This will be 0 if no session key was requested.

 

Environment

ITMS 8.1 RU7 and later

Cause

GPO Configuration. The problem is that the policy “Deny access to this computer from the network” has the user group “Local Account”.

Also, there is another GPOs that affect "Local Accounts" to be validated during authentication.

Resolution

Remove "Local Account" from the policy “Deny access to this computer from the network”