Symantec VIP Enterprise Gateway | SSL certificate created through SSL Certificate wizard does not appear in the Configuration page
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Symantec VIP Enterprise Gateway | SSL certificate created through SSL Certificate wizard does not appear in the Configuration page

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Article ID: 176594

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Updated On:

Products

VIP Service

Issue/Introduction

If adding a new SSL certificate through the SSL Certificate wizard, the certificate does not appear in the configuration page of Self Service Portal (SSP) IdP, VIP Manager IdP, and Tunnel Receiver.  This problem is seen when the Enterprise Gateway server is set up by importing the settings from another enterprise server. 

Cause

This issue is caused by a missing configuration file (valconsole.properties) in the exported configuration.

Resolution

Complete the following procedures on the VIP Enterprise Gateway machine to update the configuration page:

  1. Stop the VIP Enterprise Gateway Service.
  2. Create a backup copy of the valconsole.properties file from <VIP_EG_INSTALL_DIR>/conf folder.
  3. Edit valconsole.properties and search for the entry “keystore.count=0” and delete it. Make sure to append the following lines after Keystore(s) section:

    keystore.count=2
    keystore.0.name=DEFAULT
    keystore.0.type=JKS
    keystore.0.location=DEFAULT
    keystore.0.passwordProvider=MAUTHLICENSE
    keystore.1.name=VIPSDK
    keystore.1.type=JKS
    keystore.1.location=VIPSDK
    keystore.1.passwordProvider=MAUTHLICENSE

     
  4. Start the VIP Enterprise Gateway service.