Error "The request failed with HTTP status 401: Unauthorized" when running workflow project after deployment
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Error "The request failed with HTTP status 401: Unauthorized" when running workflow project after deployment

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Article ID: 176758

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Updated On:

Products

Workflow Solution

Issue/Introduction

The error "The request failed with HTTP status 401: Unauthorized" appears when running workflow project after deployment. The detailed message is as follows:

Error Details
Error Message:
The request failed with HTTP status 401: Unauthorized.
Message Stack:
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Symantec.Workflow.Core.HelpdeskWS.WebService.ExecuteQuery(String queryText, Int32 maxRowsToReturn)
at Symantec.Workflow.Components.ServiceDesk.FindServiceDeskContact.Run(IData data)
at LogicBase.Core.ExecutionEngine.SinglePathProcessComponentExecutionDelegate.Execute(IData data, IOrchestrationComponent comp, String& outputPath, IExecutionEngine engine, TLExecutionContext context) in c:\Stuff\projects\platform2006\core\LogicBase.Core\ExecutionEngine\ExecutionEngineDelegates.cs:line 238
at LogicBase.Core.ExecutionEngine.AbstractExecutionEngine.DoRunComp(IOrchestrationComponent comp, IData data, TLExecutionContext context) in c:\Stuff\projects\platform2006\core\LogicBase.Core\ExecutionEngine\ExecutionEngineImplementation.cs:line 42

This  problem has also been observed while running a project in debug mode.  You may see the first form appear, but then the 2nd form times out and when reviewing logs, both LAN trace logs and Workflow service logs result in 401 errors. 

Cause

The "Create Notification Server Credentials" component was not configured with the username and password that downstream project components require to run successfully. In this case, it was the "Find Service Desk Contact" component that was failing because it was being denied access to the Notification Server Web service.

One other cause that has been obeserved is that the FQDN (fully qualified domain name) of the Notification Server was entered into the Notification Server Credentials Tool.   

Resolution

Opened the "Create Notification Server Credentials" component and, in the authentication section, enter valid credentials for the Domain, Username, and Password fields.  Also make sure that the NETBIOS name of the Notification Server is entered, not the FQDN.


Applies To
Workflow Solution 6.0
Workflow Solution Advanced 6.5