Error: "The Named Pipe could not be found." when trying to deploy changes in the Symantec Mail Security Console
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Error: "The Named Pipe could not be found." when trying to deploy changes in the Symantec Mail Security Console

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Article ID: 177179

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

After installing a new license file or upgrading the current license file in the Symantec Mail Security for Microsoft Exchange (SMSMSE) console the following error is received when using the "Deploy changes" option:

"The Named Pipe could not be found."
 

Cause

This error can have multiple causes:

  1. Communication issue with the SMSMSE services
  2. A corrupted license file 
  3. Insufficient permissions for the account used by the Symantec Mail Security for Microsoft Exchange (SMSMSE) service.

Resolution

Perform the following tasks in this order until the issue is resolved:

  1. Restart the SMSMSE services for any communications issues
  2. Re-register the SMSMSE license
  3. Change the account used by the SMSMSE services.

 

To restart the SMSMSE services

  1. Go to the Services menu, by clicking Start > Run and type in services.msc 
  2. Restart the Symantec Mail Security for Microsoft Exchange service.
  3. Restart the Symantec Mail Security Utility Service.

 

To re-register the license

1. Close the SMSMSE console.
2. Go to the Services menu, by clicking Start > Run and type in services.msc
3. Stop the Symantec Mail Security for Microsoft Exchange service.
4. Stop the Symantec Mail Security Utility Service
5. Go to the directory C:\Program Files\Common Files\Symantec Shared\Licenses and move your current SMSMSE licenses to another directory, or to the desktop.
6. On Server 2008 and newer: Browse to C:\ProgramData\Symantec Shared\Licenses Note: This folder and directory are hidden. Make sure to set view to show all hidden files and folders.
7. Go to the directory C:\Program Files\Symantec\SMSMSE\<version>\Server\SpamPrevention and move the file named "SPALicense.slf" to another directory, or to the desktop.
8. Go to the directory C:\Program Files\Symantec\SMSMSE\<version>\Server\UPLOADS and move all the license files to another directory, or to the desktop
9. Go back into the Services menu and start the Symantec Mail Security for Microsoft Exchange and Symantec Mail Security Utility Service services.
10. Open the SMSMSE Console and under Admin > Licenses make sure the licenses status shows "Not Installed".  If not, press the F5 key to refresh the console to determine if the license status shows "Not Installed".  If it does not, go through these steps again.
11. Under Admin > LicensesBrowse to your current license (.slf) file then click Install

Please note that if you have installed Symantec Mail Security for Microsoft Exchange on a 64 bit version of Windows you will need to use Program Files (x86) instead of Program Files for steps 5, 7 and 8.
 

To change the account used by the SMSMSE services

Be aware that the Symantec Mail Security for Microsoft Exchange service needs to have rights to perform it's duties as well. To eliminate possible problems with service permissions complete the following steps:

1. Go to Start > Run and type services.msc
2. Locate the Symantec Mail Security for Microsoft Exchange service, Right-click it and choose Properties.
3. In the Properties dialog box click the Log On tab
4. Change the Log On from Local System Account to "This account" and choose a domain administrator.
5. Restart the service.
6. Repeat steps 2-5 for the Symantec Mail Security Utility Service.

If this resolves the named pipe error, you now know that the permissions for the Local System account are limited in some way that prevents the SMSMSE service from opening named pipes.
 

If the problem continues, please contact Symantec Technical Support.