Symantec Endpoint Protection Manager: How is Database Maintenance scheduled?
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Symantec Endpoint Protection Manager: How is Database Maintenance scheduled?

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Article ID: 177885

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Updated On:

Products

Endpoint Protection

Issue/Introduction

How is Database Maintenance scheduled in the Symantec Endpoint Protection Manager (SEPM)?

Symptoms
Database Maintenance settings can be found by going to SEPM Admin tab, Servers, Local Site Properties, and Database tab. These settings do not include a schedule, though. Attempting to test these settings by adjusting the system clock may result in frustration when old events are not removed from the SEPM database.

 

Cause

By default, SEPM database maintenance runs only at midnight and it will not run when the SEPM service is restarted.

Resolution

The following parameters in tomcat\etc\conf.properties need to be added in order to change the Database Maintenance schedule (also known as AgentSweep task):


scm.object.idletime=integer in milliseconds -- default in server is 1 month
scm.timer.objectsweep=integer in seconds --- default in server is once per day
scm.timer.objectsweep.delay=integer in seconds -- after SEPM starts, how long to delay first mainenance run

After these parameters are added to conf.properties, restart the SEPM service.

AgentSweep by default runs every day at midnight. Setting the objectsweep parameter forces this task to run according to that interval, and will also run every time the SEPM service is restarted. In a single site environment AgentSweep marks the unwanted data as deleted. In a multi site environment (replication setup), AgentSweep marks the unwanted data as deleted if the records are older than last successful replication. Records which are older than idletime and also marked as deleted will be swept out of the database permanently (reduces database size).