Messaging Gateway "Give root password for maintenance" message on failed boot.
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Messaging Gateway "Give root password for maintenance" message on failed boot.

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Article ID: 178006

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Updated On:

Products

Messaging Gateway

Issue/Introduction

While booting a Messaging Gateway (SMG) stops and displays a message on the console indicating that it has entered "emergency mode" and needs to root password for maintenance.

You may see one of the following sets of text:

EXT4-fs error (device sda2): [error details]
Welcome to emergency mode! After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to
try again to boot into default mode.
Give root password for maintenance
(or type ^D to continue):

Or:

*** An error occurred during the file system check.
*** Dropping you to a shell: the system will reboot
*** when you leave the shell.
Give root password for maintainance
(or type Control-D to continue):

Cause

The SMG appliance has encountered an unrecoverable disk error and cannot start.

Resolution

SMG has no root password and the root account is disabled so root login is not possible.

Virtual Machine Installations

This is an unrecoverable disk error and the SMG virtual machine will need to be either reinstalled and the most recent backup restored or the virtual machine should be rolled back to the most recent snapshot.

Hardware Appliances

  1. Power on the system and press <F2> during POST to enter the System Setup.
  2. CTRL + M 
  3. Configure > View > Check consistency 
  4. Objects > Physical drive


If the Hardware Diagnostics reports any errors, please document the errors via screenshot or photograph, then contact Broadcom Technical Support. If no error is reported a complete rebuild of the appliance will be necessary.

This will require that you have the OSRestore  ISO installation file for the version of SMG you were running. This should be available from the Broadcom Support Portal.