All Email being received by the Symantec Messaging Gateway are rejected with SMTP error "554 Recipient address rejected: User unknown"
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All Email being received by the Symantec Messaging Gateway are rejected with SMTP error "554 Recipient address rejected: User unknown"

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Article ID: 178116

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Updated On:

Products

Messaging Gateway

Issue/Introduction

After deploying the Symantec Messaging Gateway (SMG), All Email to one or more domains you are hosting, or Email you are sending to one or more external domains is rejected by the SMG with a reported error "554 Recipient address rejected: User unknown".

Symptoms
The sender of an Email received an NDR notification from your Messaging Gateway with the following content :


Remote host said: 554 Recipient address rejected: User unknown

 

Environment

Symantec messaging gateway all versions

Cause

There are two known reasons why you might be experiencing email delivery issues, depending on the direction of the mail affected:

1. Receiving Email:

    Recipient domain not added: The recipient domain may not be added to the "Domains" configuration of the SMG Control Center. This means that the Messaging Gateway doesn't recognize the domain as a valid recipient, so emails are rejected.
    Incorrect domain name: The domain name may have been entered incorrectly in the "Domains" configuration. This can also lead to email delivery failures.

2. Sending Email:

    Incorrect MTA interface: Your downstream Mail Transfer Agent (MTA) might be sending email to the Messaging Gateway on the Inbound interface instead of the Outbound interface. This causes the email to be routed incorrectly and ultimately leads to delivery failure.

 

Resolution

For issues receiving Email to the Messaging Gateway from external domains:

Ensure that the recipient domain, is correctly entered into the Control Center Protocols->Domains page.

For further information on the Local Domains configuration, please consult the Symantec Messaging Gateway Administration Guide at the following location:

http://www.symantec.com/business/support/documentation.jsp?language=english&view=manuals&pid=53991

For issues sending Email via the Messaging Gateway to external domains:

Ensure that your downstream MTA's SMTP Connector/Smarthost is connecting to the Outbound Interface IP/port specified in the Messaging Gateway's SMTP configuration.

If you are using Messaging Gateway version 8.0.3 or prior, with version 9.0.X, you can now use the same IP address and port for both inbound messages and outbound messages potentially avoiding this issue from occuring. With version 9.0.X, the Scanner will check the outbound mail acceptance settings to determine if a message is inbound or outbound.